or Connect
EpicSki › The Barking Bear Forums › On the Snow (Skiing Forums) › Tuning, Maintenance and Repairs › Mounting Atomic Pro-Trak Bindings, Please Help
New Posts  All Forums:Forum Nav:

Mounting Atomic Pro-Trak Bindings, Please Help

post #1 of 3
Thread Starter 

Hey guys, first time poster, sorry...

 

 

Recently picked up a set of Atomic Blackeye's with XTO 12s.  Binding install appears to be straight-forward, but I think I'm missing something.

 

Anyone here know the pro-trak system?

 

It appears I simply place the metal strip with the sole-adjusting holes onto the pro-trak frame mounted to the ski.  Then, I slide on the front and rear bindings onto the frame, engaging them with the metal strip.  Lifting the adjust ment tabs and sliding into position the correct sole length.

 

However, is there some further locking step to more firmly secure the bindings to the protrack frame?  As they sit now, there is a good bit of play between the bindings and the frame mounted to the ski.  Especially in the front.  I jsut don't believe something that loose is considered installed.

 

So, what am I missing?  A clamp-down or set screw somewhere?

 

Thanks in advance,

 

John

post #2 of 3
Thread Starter 

Found the Atomic mounting instruction PDF.  They are installed correctly.

 

Is this play in the toe-piece normal?

post #3 of 3

I have the Salomon set-up that is the same as your Atomic bindings (Atomic and Salomon are owned by the same company).

 

Yes, there is a bit of play in the bindings when you don't have a boot clicked-in.  Once you put a boot into the binding all that play goes away.  Or, at least it does on my bindings...

 

 

Z

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Tuning, Maintenance and Repairs
EpicSki › The Barking Bear Forums › On the Snow (Skiing Forums) › Tuning, Maintenance and Repairs › Mounting Atomic Pro-Trak Bindings, Please Help