or Connect
EpicSki › The Barking Bear Forums › EpicSki Feedback/Tech Talk › The Bug Report › Disabling Bugs - Some New after recent Push
New Posts  All Forums:Forum Nav:

Disabling Bugs - Some New after recent Push

post #1 of 9
Thread Starter 

*** I'm writing this post in Notepad and pasting it into the Ctrl-V Paste-Editor because that seems the only possible way for me to post anything now. ****

In Firefox, ever since the recent 'push' a few days ago the Editor no longer works after the page is fully loaded/re-loaded(?).

Specifically, while a page/thread is still loading and the Editor has first popped into existence I'm able to *quickly* put the cursor into it and start typing.  At this point, everything acts 'normal' - I can see the cursor flashing at the point of edit, formatting buttons work properly (in Firefox), editing keys (del, ins, et al) work properly and so on.

But when the page finally finishes loading it 'jumps' at the last minute causing the editor to disappear, then reappear as before - but no longer working worth a damn.  The text-cursor is now invisible, editing keys no longer work, carriage-returns don't work, arrow-keys don't work and so on.  The Format Buttons don't work and I'm no longer able to highlight and select text to cut or copy it.  All basic Editing features/keys simply die with only the letter and number keys still working.

It seems the editor works fine until some late loading process/function kills off the working editor and reloads an un-working editor in its place (it clearly disappears briefly, then reappears).  

When I try to paste text that I've written elsewhere I get a 'security pop-up' box that requires me to redo the paste-function into that box before it will take it ( something no other website does).  Ironically, inside this Editor Box all normal editing functions work just fine - Which is how I'm getting this information posted right now!

A second Firefox problem (not sure if related) is that the auto-placement feature that formerly took me directly to the most recent unread-posts no longer works properly.   When I hit the 'unread' Button I never know where I'll end up ...
- Top of last actual page (even if previous pages are unread)
- Last actual post (even if previous posts are unread)
- A *Random* location on the last page containing a post previously read

And while this Roulette Wheel of "Last Post Read" placement is being spun, the screen jumps around like a jackrabbit about 6 or 8 times causing a bit of vertigo.  This started more than a month ago but became greatly worse a few days ago (when the editor also went schizoid).

A third Firefox problem is the tendency of my screen to jump around whenever I press one of the buttons available.  This happens randomly and with random placement results.  Each time I press a button it's a gamble what it will actually do.  

The random button-click outcomes are ...
a) Nothing happens, requiring a second click attempt
b) The cursor jumps to a new, random location
c) The whole screen jumps to a new location regardless whether the button's task succeeded or not
d) The button works properly (making me wonder what it secretly did without my knowing...)

A fourth set of problems occur in IE 6.0. under both Win XP and Win2000

Here, the Editor DOES permit the normal edit-keys to work, does show the cursor and does allow normal movement in the text box - but none of the Formatting Buttons appear (for Bold, Links, Image-insert, etc.) making formatting impossible. 

Also, when I try to press the 'Preview' button in IE (hoping to get to another editor with visible Buttons) I simply Jump to the top of the current page.  Nothing else happens, no 'preview' mode shows up.

A fifth problem occurs with both Firefox and IE under both Win XP and Win2000.  

In this case pressing the 'Preview' button brings up that screen - but the editor box is now filled with what looks like a form of HTML instead of WYSIWYG formatted text.  Multiple reload attempts come up with the same thing until (randomly) it comes up with regular text - or I just give up and forget about posting anything (which happens a lot these days).

STILL: - Firefox 3.5.8, IE 6.0
STILL: Win XP, SR2 on one machine, Win2000, SR4 on another - same problems on each machine)

Yes, I turned off all ad-blockers, flash blockers, internet-security and such on both machines - nada.  The first Editor Problem listed above started right after you did that update a little while back (mere days ago).

I notice that some buttons "highlight" themselves a moment after the mouse cursor is held over them.  If a 'click' occurs before the highlight shows up, the button often doesn't work.  In some random cases Buttons seem unwilling to highlight regardless how long the mouse is held over them.

I'll note that I work on a variety of websites (both through the public 'Net and over a VPN) using all manner of Office Application, Writing Apps, Server Admin Apps, SW Development Editors, ERP Apps and a zillion other Apps.  NONE of them show problems even remotely similar to all the problems I'm seeing with these Huddler Applications.  This website is the only place I experience the kind of problems described above.  It's getting pretty frustrating.


post #2 of 9

Didn't know that there had been a push, but I've definitely noticed issues with where I've been coming into threads lately.  I thought it was just me being too impatient.

post #3 of 9

Michael, take a look at your My Profile, and Edit Detailed Settings.  Go to the bottom of the page.  Are you using the full page editor as default?

post #4 of 9
Thread Starter 

Wow Cirque - good wild grab at the ether..!


I just checked my settings and no, "Default to the full page editor" was NOT checked.


Things were not working anyway so I turned that feature ON (checked the box), then logged out and logged back in again.  Reloading this thread I tried this editor box again ..... Nope, still barely worked.


At that point I took some screen snapshots during the load process.


First Image was taken while the screen was *mostly* loaded with an Editor form now visible...

-- a) No formatting buttons available yet

-- b) Cursor shows up and editing keys all work as does CR

-- c) Note 'swirly' progress icon in left portion of that browser-Tab indicating "still loading"



Second Image was taken after the page was fully loaded

-- a) The whole screen image seems to 'flicker' as the editor form is replaced

-- b) The new Editor form that popped up had Formatting buttons

-- c) actual editing features no longer work (no CR, no del/ins/arrow/etc keys work)

-- d) Note the 'swirly' progress icon mentioned above has been replaced with the Epic Bear



After creating these images (intended for email as the post editor simply wasn't working) I went back to my profile and unchecked that "full page editor" check-box.  Just for laughs, i reloaded this page - - - and the Editor actually worked normally again!


In disbelief, I reloaded the page several times thinking it wouldn't last, but it seems to be hanging in there (thus I'm taking advantage of it and adding the images above).


After posting this (assuming it 'takes') I'll try re-checking that check-box and see if it breaks things again.





post #5 of 9
Thread Starter 

Test confirmed.


When I re-checked that "full page Editor" check-box, the badly behaved Editor returned in exactly the same way as before.  First a working editor appears sans format buttons, then it goes away, replaced with a non-working editor. 


( Never do I see an actual "Full Page Editor" as is implied by that check-box. )



For the record, that check-box was *cleared* when I first looked at it, yet the Editor failed.  Once that check-box was

1) Manually Checked,

2) Settings Saved,

3) Manually Un-Checked

4) Settings Saved


... the Editor returned from it's self imposed strike.


I suspect some record somewhere must have retained a stored value for that check-box even though it was cleared.  If that value is stored in multiple locations (or perhaps a Null was stored somewhere) then that might have caused the problem until manually fixed.


So, it seems to be 'repaired' to some degree.  Again, good catch Cirque.  Curious though - just how did you make that connection?




The "screen jumping around" problem hasn't been checked yet, but I'll let you know if that's changed at all a bit later as I've a few things to catch up on elsewhere.


How are records stored as to which posts have been 'read' by a user?  I don't see anything in my browser cookies so I'm guessing it's stored on the Epic server by user ID?.  If so, could those records be hosed up causing the screen to hunt and peck while looking for a place to land?  Maybe some Nulls or Empty Fields in there somewhere?




PS: After examining those Editor Images I posted, feel free to delete them as each is 2 meg in size and they server no useful purpose once you've seen them...

post #6 of 9
Thread Starter 

Oops.. spoke too soon.  The Editor has died again and I'm back to the same problems as before after spending maybe 45 minutes inactive.

Tried to toggle that "full page" things again but it didn't work this time and I'm back to using the "Paste Editor" box to compose text.

A few minutes ago I tried loading a few threads that I've never looked at before in other forums.  In each case the page loaded initially with a view of the very first post of the first page (as one would expect). 

Then, just as the page finishes loading, it jumps me down to the last post on that page, though I've never read any of that thread before.

Didn't have a chance to test other threads where I've posted at some point but new posts are now present.


post #7 of 9
Thread Starter 


Hey- wait...


Immediately after I posted the post above (like, 10 seconds later) the editor is working "normally" again.


So - my guess is that the "submit" action/process must reset something that re-enables the editor to work correctly again.  I'll try to open another thread in another window and see if that thread works after its initial load...


...?  ...?  ...?


... OK, I'm back.  Just discovered that when a thread *initially* loads the Editor follows that bum pattern described above with a non-working editor replacing a partially working editor text box sans format buttons.  I suspect that if I post something via the Paste Editor (the one that shows up after a ctrl-v) that the working editor will show up when the thread reloads after 'taking' the just-submitted post..




post #8 of 9

I have referred this for a technical review.  I'm good at ether, but usually call in some help if my first shot misses.

post #9 of 9
Thread Starter 

OK - re-read my original post (and others) in this thread!

EXACTLY the same symptoms are back again as of today.  

On the 26th things were working fine (I posted a few things and didn't notice any problems).

I tried the checkbox thing again and it makes no difference.

When the Editor Form first loads it seems to be working but then RELOADS as the page finishes up doing something (probably loading more ads).  The reloaded version simply doesn't work.

(posted via Notepad , cut & paste)


  Edit - oddly, when I chose to Edit this existing post, the Editor keys work here, but not in any other thread...!?

 (and yes, I tried it on both machines - same issues on both Win2k and WinXP)


New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: The Bug Report
EpicSki › The Barking Bear Forums › EpicSki Feedback/Tech Talk › The Bug Report › Disabling Bugs - Some New after recent Push