or Connect
EpicSki › The Barking Bear Forums › On the Snow (Skiing Forums) › Tuning, Maintenance and Repairs › Dilettante question about Marker 3Motion Bindung
New Posts  All Forums:Forum Nav:

Dilettante question about Marker 3Motion Bindung

post #1 of 4
Thread Starter 

Hello everyone,
 

I have a Volkl skis with Marker 3Motion TP Light 10.0 Binding. The thing is that one silver screw (for adjusting forward pressure) doesn't make its standard 'click' sound. It just screws in and out tightly with the distinctive stops. Do you think this is ok or there is a problem?

 

Thank you!
Igor

post #2 of 4

Have you talked with Marker yet, they would know for sure ?

post #3 of 4
Thread Starter 

Yes, a guy from Volkl said I should not ski with this binding, so I'm sending the skis back to seller.

post #4 of 4
Quote:
Originally Posted by trepet View Post
 

Hello everyone,
 

I have a Volkl skis with Marker 3Motion TP Light 10.0 Binding. The thing is that one silver screw (for adjusting forward pressure) doesn't make its standard 'click' sound. It just screws in and out tightly with the distinctive stops. Do you think this is ok or there is a problem?

 

Thank you!
Igor


The worm screw is more than likely damaged from someone adjusting it with the boot in.  Always adjust with the boot out.

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Tuning, Maintenance and Repairs
EpicSki › The Barking Bear Forums › On the Snow (Skiing Forums) › Tuning, Maintenance and Repairs › Dilettante question about Marker 3Motion Bindung