or Connect
EpicSki › The Barking Bear Forums › On the Snow (Skiing Forums) › Ask the Boot Guys › K2 Pinnacle 130 Locking mechanism ISSUE
New Posts  All Forums:Forum Nav:

K2 Pinnacle 130 Locking mechanism ISSUE

post #1 of 3
Thread Starter 

Hello,

I purchased a pair of K2 Pinnacle 130 touring boots from The Destination in North Vancouver, BC. We went through the standard fitting process and we determined that the Pinnacle would be the best fit. However, when I tried to flex the boots in ski mode, we found that the locking mechanism wasn't engaging, meaning that the boot would flex all the way and had no stiffness to it.
 

They assured me that they would contact the K2 rep and fix it, so I went ahead and purchased the boots and left them at the shop while they worked on it.
 
I just picked them up from The Destination this morning and I've been trying them out at home. The locking mechanism seems to be "better", but I watched some K2 Pinnacle 130 reviews on Youtube and no one seems to be having the same problem. I decided I would make a short video so you can see exactly what's going on. Here's the Youtube link:

https://www.youtube.com/watch?v=eIUMdw8PLJo&feature=youtu.be
 

The locking mechanism still doesn't seem to be working properly, as you can see from the video. Any idea what I should do?

Thanks for the help!
Filip

post #2 of 3

Customer satisfaction is important to all retailers----I would return to your dealer and see if he can help.

 

mike

post #3 of 3
Thread Starter 

Thanks Mike, will do.

Hopefully it's an easy fix!

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Ask the Boot Guys
EpicSki › The Barking Bear Forums › On the Snow (Skiing Forums) › Ask the Boot Guys › K2 Pinnacle 130 Locking mechanism ISSUE