or Connect
EpicSki › The Barking Bear Forums › On the Snow (Skiing Forums) › Ask the Boot Guys › Something wrong with my boots?
New Posts  All Forums:Forum Nav:

Something wrong with my boots?

post #1 of 5
Thread Starter 

So I am wearing a pair of Dalbello Axion 75 (size 26.5). I am not sure whether this is a boot problem or it is just my leg but I cannot get my right skis on edge. Do you guys have any input? I previously had an injury on my left knee (torn meniscus and partially torn acl). Thanks alot

post #2 of 5

what is the shell fit like on the boots?

 

do you have footbeds

 

are the boots red?

post #3 of 5
Thread Starter 

No I do not have footbeds and the color of my boots is grey/white. It only happens with my right foot. My left foot is normal.

post #4 of 5
Thread Starter 

Any suggestion ?

post #5 of 5

we need a whole lot more information to even guess at what is going on

 

the colour question was a joke but we do need to know the shell fit and how the foot fits the boot, without some form of footbed your foot is most likely unstable n the boot this will certainly not help getting the ski on edge, but equally it might be the cuff alignment of the boot or something else all together

 

you really need to take the boots to a good fitter, only with the boot and your feet in front of a good fitter will you get the answers as to what might be happening, it could be really simple or it could be something more complex but without your feet it is impossible to tell for sure 

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Ask the Boot Guys
EpicSki › The Barking Bear Forums › On the Snow (Skiing Forums) › Ask the Boot Guys › Something wrong with my boots?