EpicSki › The Barking Bear Forums › On the Snow (Skiing Forums) › Tuning, Maintenance and Repairs › marker schizo bindins wont move back
New Posts  All Forums:Forum Nav:

marker schizo bindins wont move back

post #1 of 8
Thread Starter 

i am on vacation in france(val disere) and i went to move my bindings back form centered to +4 ish and when i moved one ski back the metal in between the back and the front just buckled and the rear part did not move back at all... i banged it etc and still no luck i managed to get them back working so i could fit a boot in in centred but now the metal wire is bent slightly...

 

so right now i am stuck with them centered...

 

anyone got any ideas how to fix in the short and long term???

post #2 of 8

You tried to move them back without a boot clicked in, right?  That's where you went wrong, that keeps everything from messing up.  If you can't figure the mechanism out take it to a shop that sells the Schizo to reset it.

post #3 of 8
Thread Starter 

thanks but the boot is in... skied on the GS skis today but want to use the Kung Fujas in park tomorrow, tried again on the one that is stuck and i managed to get it from +6 to +5 but really want it +4 and the back part wont budge backwards!!!

post #4 of 8

Mine move just fine through the whole range of adjustment both with and w/o the boot in the binding.

 

I'm guessing either improper installation of the binding itself or if you tried to move it while either the toe or heel were frozen (as in cold frozen....not mechanically frozen) then only one or neither of the units would actually move.  Try it again when you know the binding is defrosted.

post #5 of 8
Thread Starter 

so frustrating... didnt use them today so they had been at room temperature for 24 hours...

 

 

post #6 of 8

Get to a shop that's an official Marker distributor. 

post #7 of 8

Yeah - this helps.  Then the Marker rep can come in and tell you it is your fault. 

 

post #8 of 8
Thread Starter 

well home now... 

 

havent had time to take them to the shop to see what they say...

 

have however stripped the ski... everything moves fine and nothing sticks... put everything back on at +4 then tried to move with a boot in and still same problem moves forward fine but not backwards... i assume the buckled cable is to blame... as you can see - 

 

http://www.imagebam.com/image/1f824a123672611

 

going to mount at +4 and just leave them as non moving bindings!!!!!! not  fan of these bindings... tempted to take my 912 bindings off my 1080s!!!

 

 

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Tuning, Maintenance and Repairs
EpicSki › The Barking Bear Forums › On the Snow (Skiing Forums) › Tuning, Maintenance and Repairs › marker schizo bindins wont move back